Pomoc programu VATowiec

VATowiec

1. Księga Dokumentów

2. Rejestry VAT

3. Bank, kasa i kompensaty

4. Środki Trwałe

5. Plan Kont

Program można aktualizować poprzez pobranie nowej wersji z internetu pod adresem http://pk.inet.pl/brv.htm
lub z mirrora we Wrocławiu


Praca w sieci komputerowe

Praca w sieci komputerowej.

Programy mogą pracować w sieci komputerowej współdzieląc wszystkie dane. Nie ma żadnych ograniczeń w tym zakresie i istnieją metody optymalizacji tej pracy.
1. wszystkie współdzielone dane powinny znajdować się na komputerze udostaniającym dysk w taki sposób, żeby był widoczny katalog \BR\BAZY\
2. pliki programów, czy cała zawartość \BR\PROGRAMY może i powinna znajdować się na dysku lokalnym np. C:\BR\PROGRAMY

Po uruchomieniu programy skanują dyski lokalne i zmapowane dyski udostępnione w poszukiwaniu katalogu \BR\BAZY. Jeśli chcesz ograniczyć ilość skanowanych dysków, to uruchamiaj program z parametrem /S.

Przykład:
Firma posiada siedem komputerów połączonych w sieć komputerową, ale nie posiada serwera:
SZEF, GK, KASA, KSIEGOWA1, KSIEGOWA2, SPRZEDAZ, ZAKUPY
Komputer GK (Głównej Księgowej) posiada duży dysk lokalny podzielony na partycje i w związku z tym decydujemy się na instalację danych firmy w katalogu D:\BR\BAZY\FIRMA. Ten dysk udostępniamy w sieci i mapujemy na pozostałych komputerach. Litera przydzielana mapowanemu dysku możne być dowolna jednak nie używa się liter określających domyślnie napędy dyskietek lub CD-ROM. Załóżmy, że przyjeliśmy zasadę iż mapujemy na literę F.
Wówczas otrzymamy następującą konfigurację:
GK D:\BR\BAZY\FIRMA
SZEF i pozostałe F:\BR\BAZY\FIRMA
Kolejny etap polega na optymalizacji działania oprogramowania w sieci. Jak można się domyślać działania programów jest szybsze, gdy maksymalna ilość danych jest odczytywana z dysku lokalnego np.C. Jednak stoi to w sprzeczności z pracą sieciową i dlatego pozostaje rozwiązanie polegające na przeniesieniu oprogramowania i wszystkich możliwych danych na dysk lokalny. Tak więc wystarczy, że skopiujemy cały katalog \BR\PROGRAMY z dysku Głównej Księgowej na dysk lokalny przygotowywanego komputera. Uzyskamy wtedy na komputerach C:\BR\PROGRAMY i dane na dysku F:.
Nie istnieje potrzeba kopiowania katalogu z danymi (BAZY), a wręcz nie powinno się tego robić żeby uniknąć nieporozumień w przyszłości.
Powyższa konfiguracja jest wystarczająca do rozpoczęcia pracy w sieci komputerowej.
Pozostaje jeszcze do rowiązania problem aktualizacji oprogramowania i archiwizacji danych.
Aktualizacja ( i instalacje) odbywają się domyślnie do katalogu C:\BR\PROGRAMY i w związku z tym wystaczy, że wykonamy aktualizację na jednym z komputerów, a natępnie "ręcznie" skopiujemy całą zawartość katalogu na udostępniany dysk np. F:\BR\PROGRAMY.
Zaznaczyłem "ręcznie" w cudzysłowiu ponieważ może to wykonać jakiś program lub po prostu polecenie xcopy.
...

Archiwizacja danych należy do bardzo ważnych operacji dających pewność iż po uszkodzeniu lub zniszczeniu baz nasza praca nie zostanie zmarnowana.


Wieloodziałowość

Oprogramowanie posiada mozliwość pracy wieloodziałowej.
Pracę tą można zorganizować w dwóch systemach komunikacyjnych:
- niezależnym
- zależnym

System komunikacyjny niezależny polega na przesyłaniu plików wyeksportowanych danych i importowaniu ich u adresata. Niezależność wynika z faktu, iż nie są przenoszone identyfikatory, unikatowe numery dokumentów, kontrahentów, towarów itd. Każdy z oddziałów ma swoją własną i niezależną bazę danych.

System komunikacyjny zależny polega na wysyłaniu i odbieraniu przesyłki, która zawiera pełne dane z bazy oddziału tj. włącznie z unikatowymi numerami rekordów jak np. identyfikator dokumentu, kontrahenta, towaru itd.

Oba systemy mają swoje właściwości.


Klawiatura

Praca na klawiaturze

Ze względów na potrzebę przystosowania oprogramowania do masowego wprowadzania danych, zastosowano wszystkie możliwe skróty klawiszone blisko klawiatury numeryczej.

[Enter] - rozpocznij/zakończ edycję lub wybór z listy
[Esc] - zakończ lub zrezygnuj
[Ins] - nowa pozycja w tabeli
[Del] - usuń pozycję z tabeli

Pozostałe skróty do menu i poleceń "guzikowych" są ustalone w/g zasady pierwszej lub podkreślonej litery w nazwie. Wywołanie tych poleceń odbywa się za pomocą [lewy Alt]+litera.

Ponadto:
F1 - pomoc
F5 - sumuj ( jeśli jest polecenie sumowania )
F7 - szukaj
F8 - szperaj ( to rodzaj poszukiwania zagnieżdżonego )
F9 - drukuj
F10 - menu


Alerty

Jak widać są proste w obsłudze, a większość robi się sama :)

Jednak zaglądasz tutaj więc oczekujesz czegoś więcej.
Kolumna "akcja" może zawierać:
"komunikat" - wywołanie okienko informacyjne ze zdefiniowanym tekstem
"archiwum" - uruchomienie archiwizacji
"funkcja" - uruchomienie wewnętrznej funkcji programu: ImportStalych(), ImportKursow()
"program" - uruchomienie wskazanego programu zewnętrznego

Zatrzymam się na akcji "funkcja". W kolumnie "Komunikat/Nazwa" wpisz "ImportStalych()" ( bez znaków cudzysłów). Po ustawieniu parametrów czasowych program uruchomi import stałych rocznych/miesięcznych/stóp odsetkowych z Internetu. Analogicznie działa funkcja ImportKursow().


Synteza mowy

Uruchomienie syntezy mowy w programie sprowadza się wykonania kliku czynności:

1. instalacja programu "Rozmowa" z http://mowa.wp.pl
2. ustawienie opcji "Dźwięk .." na "WP" w stałych programów

Jeżeli masz syntezator mowy IVO, to wpisz do "Dźwięk" słowo "IVO".

reszta robi się sama :)

System syntezy mowy jest uruchamiany, czyli program "gada" podczas wyswietlania okienek informacyjnych i poruszania się w tabelach za pomocą klawisza kursora "w dół".


Księga Dokumentów

Księga Dokumentów ( Książka Przychodów i Rozchodów )

Wszystkie dokumenty związane z działalnością gospodarczą powinny być zaewidencjonowane.
Przyjęto zasadę, że w księdze muszą znajdować się wszystkie dokumenty, dotyczące zakupów i sprzedaży VAT, kosztów prowadzenia rachunku bankowego, kosztów związanych z amortyzacją środków trwałych i opisujących wiele innych zdarzeń gospodarczych. Zasada ta pociąga za sobą zwielokrotnienie zapisów i narzucenie kolejności wykonywania zapisów, którą można ująć w regule, że do Księgi zapisujemy na końcu. Program posiada mechanizmy wspierające nas w rzetelnym prowadzeniu księgi. Mechanizmy te, to nic innego jak automatyczne przeniesienia i sumowania oraz dekretacje.

Trzymając się zasady: zaczynamy zapis dokumentów VAT od rejestrów VAT, zaoszczędzimy sobie wiele zbędnej pracy.
Podobnie należy postępować z dokumentami typu wyciąg bankowy lub nota odsetkowa.
Mówiąc krótko, wykonujemy zapis do Księgi Dokumentów na końcu.

Ewidencja musi pociągać za sobą inne korzyści. Oprócz wydruków, czy stałej kontroli finansów firmy możemy uzyskać informację o wysokości podatku do zapłacenia. Oczywisty jest fakt potrzeby sprawdzenia i ewentualnego uzupełnienia stałych rocznych, dotyczących podatków i statusu Twojej firmy w ewidencji kontrahentów. Jeśli jesteś osobą fizyczną prowadzącą działalność gospodarczą, to powinien tam wystąpić zapis "OF" i analogicznie dla spółek "SC", "SJ", "SZ", "SA" itd.
Mając uzupełnione wszystkie niezbędne dane możesz sprawdzić stan swoich finansów w menu "Zestawienia" -> "Podatki" po uprzednim uruchomieniu sumowania w Księdze Dokumentów ( guzik "Sumuj" ).

Przejdźmy do zapisu dokumentu do KD.
Załóżmy, że chcemy wpisać Dowód Wewnętrzny zawierający informacje o poniesionych kosztach.
Kolumna zatytułowana "Data" powinna zawierać datę księgowania kosztu. Idąc dalej, w polu "Rodzaj Dokumentu" można wpisać "DW".
Zatrzymajmy się na chwilę przy tej kolumnie. Program nie narzuca żadnych obowiązkowych skrótów, ale warto stosować ogólnie przyjęte jak np. DW - dowód wewnętrzny, FA - faktura, KO - korekta, PW - przychód wewnętrzny, RW - rozchód wewnętrzny, MM - przesunięcie magazynowe ;-) itd. nie zapominając o NT, WB, RK. Pomimo braku ograniczeń w stosowaniu skrótów należy zaznaczyć, że program przenosząc automatycznie dokumenty z rejestrów VAT lub np. środków trwałych stosuje właśnie wyżej wymienione. Treść dowodu wewnętrznego powinno się umieścić w notatce drukowanej, wówczas mamy możliwość wydrukowania dokumentu.

Istnieje dokument, który stosuje się wyłącznie w pełnej rachunkowości i jest nim PK - polecenie księgowania.
Wpisując PK do księgi powinniśmy zwrócić uwagę, że w kolumnie "Kwota" powinna być wartość odpowiadająca poniesionemu kosztowi lub przychodowi.

W działalności osoby fizycznej pojawia się dodatkowe księgowanie składek ZUS. Są dwa sposoby. Pierwszy polega na księgowaniu bezpośrednim wszystkich składników takich jak:
- kategoria "K" kosztów, będąca sumą składek społecznych i funduszu pracy
- kategoria "O" od podatku, będąca częścią składki zdrowotnej ( aktualnie 7,75% podstawy )
- kategoria "Q" od zysku, będąca resztą składki zdrowotnej ( aktualnie 8%-7,75% podstawy )

skladki_zus.gif (3834 bytes)

Drugi ze sposobów polega na utworzeniu wzorca listy płac i odpowiednich składników w programie Kadrowiec. Metoda ta wymaga pewnego wkładu pracy w definiowanie składników odwołujących się do stałych miesięcznych, ale później nie wymaga czasochłonych obliczeń i pilnowania zmian wielkości składek ( istnieje możliwość importowania stałych z Internetu ). Pełny opis znajduje się w pomocy do programu Kadrowiec.


Rejestry VAT

Ustawiając jedną z opcji "sprzedaż" lub "zakup" wybierzesz dane rejestru sprzedaży lub zakupu.
Jak widać oba rejestry niczym się nie różnią pod względem wyglądu i obsługi manualnej.
W pierwszym i ostanim wierszu rejestru są przechowywane podsumowania w skali roku i miesiąca ( jeżeli nie widać tych wierszy, to uruchom reindeksację z menu "System"). Sumy te są aktualizowane na żądanie tj. po "naciśnięciu guzika" sumuj.
Zrezygnowano z automatycznej aktualizacji sum z dwóch względów, po pierwsze automat spowalnia pracę, a po drugie każdorazowe przeliczenie obciąża sieć, czyli spowalnia pracę wszystkim pozostałym użytkownikom.

Nowy dokument dodajemy za pomocą guzika "Dodaj" lub klawisza [Ins] albo wybierając z menu podręcznego (prawy klawisz myszy) opcję "Dodaj".
Następnie uzupełniamy dane w kolejnych polach w wiersza. W najprostrzej postaci wystarczy wypełnić pozycję rejestru VAT. Jeśli jednak na fakturze występuje inna stawka VAT niż domyślna lub kwoty w stopce VAT faktury nie zgadzają się z obliczonymi, to należy przejść do stopki VAT rejestru (klawiszem [Tab]) i wpisać właściwą stawkę lub stawki i kwoty. Powszechnie stosowana metoda księgowania polegająca na wypełnieniu specyfikacji dokumentu jest ostatnią metodą wprowadzania dokumentu w programie VATowiec. Wówczas to trzeba kliknąć guzik "Specyfikacja" ( lub [Alt]+[S] ) i uzupełnić wszystkie pozycje specyfikacji.

Wydruk wybranego dokumentu wykonujemy poprzez wybranie dokumentu z listy i kliknięcie na ikonę drukarki ( lub menu Pomoc -> Drukuj ). Jeżeli chcemy wydrukować rejestr, to należy zaznaczyć wiersz podsumowania ( pierwszy lub ostatni ) i analogicznie, kliknąć na ikonę drukarki.
Istnieje możliwość wydruku na każdym dokumencie loga firmy zapisanego w pliku graficznym. W tym celu trzeba przygotować taki plik i zapisać w katalogu firmy \BR\BAZY\<firma>. Format pliku powinien być zgodny z jednym z formatów graficznych: JPG, TIF, PCX lub PNG. Program domyślnie przyjmuje możliwość wydruku logo dla faktury VAT. Decyzję o wydruku można podejmować w każdej chwili zaznaczając odpowiednie pole w zestawieniu menu System -> Wydruki. Ponadto należy zaznaczyć, iż program sprawdza obecność pliku logo.* w katalogu firmy i wybiera pierwszy zgodny z dozwolonymi formatami graficznymi.

Często zadawane pytania:
1. Jak wydrukować fakturę:
Po wprowadzeniu dokumentu, czyli najważniejszych danych nagłówka i specyfikacji kliknij na gudzik "Drukuj" lub naciśnij klawisz F9.

2. Jak zaksięgować naprawę pojazdu finansowaną z ubezpieczenia:
- zaksięguj DW ( dowód wewnetrzny ) do Księgi Dokumentów w kwocie przyznanego odszkodowania
- zaksięguj fakturę za naprawę w rejestrze VAT zakupu, odliczając VAT i koszty


Operacje walutowe

Ustawiając jedną z opcji "sprzedaż" lub "zakup" wybierzesz dane sprzedaży lub zakupu.
Jak widać oba wykazy niczym się nie różnią pod względem wyglądu i obsługi manualnej.
W pierwszym i ostanim wierszu wykazu są przechowywane podsumowania w skali roku i miesiąca ( jeżeli nie widać tych wierszy, to uruchom reindeksację z menu "System"). Sumy te są aktualizowane na żądanie tj. po "naciśnięciu guzika" sumuj.
Zrezygnowano z automatycznej aktualizacji sum z dwóch względów, po pierwsze automat spowalnia pracę, a po drugie każdorazowe przeliczenie obciąża sieć, czyli spowalnia pracę wszystkim pozostałym użytkownikom.

Nowy dokument dodajemy za pomocą guzika "Dodaj" lub klawisza [Ins] albo wybierając z menu podręcznego (prawy klawisz myszy) opcję "Dodaj".
Następnie uzupełniamy dane w kolejnych polach w wiersza. W najprostrzej postaci wystarczy wypełnić pozycję ewidencji. Jeśli jednak na fakturze występuje inna stawka VAT niż domyślna lub kwoty w stopce VAT faktury nie zgadzają się z obliczonymi, to należy przejść do stopki VAT (klawiszem [Tab]) i wpisać właściwą stawkę lub stawki i kwoty. Powszechnie stosowana metoda księgowania polegająca na wypełnieniu specyfikacji dokumentu jest ostatnią metodą wprowadzania dokumentu w programie VATowiec. Wówczas to trzeba kliknąć guzik "Specyfikacja" ( lub [Alt]+[S] ) i uzupełnić wszystkie pozycje specyfikacji. Przed tym jednak pamietaj o ustaleniu rodzaju dokumentu, wybraniu waluty i wpisaniu jej kursu.

Wydruk wybranego dokumentu wykonujemy poprzez wybranie dokumentu z listy i kliknięcie na ikonę drukarki ( lub menu Pomoc -> Drukuj ).
Istnieje możliwość wydruku na każdym dokumencie loga firmy zapisanego w pliku graficznym. W tym celu trzeba przygotować taki plik i zapisać w katalogu firmy \BR\BAZY\<firma>. Format pliku powinien być zgodny z jednym z formatów graficznych: JPG, TIF, PCX lub PNG. Program domyślnie przyjmuje możliwość wydruku logo dla faktury VAT. Decyzję o wydruku można podejmować w każdej chwili zaznaczając odpowiednie pole w zestawieniu menu System -> Wydruki. Ponadto należy zaznaczyć, iż program sprawdza obecność pliku logo.* w katalogu firmy i wybiera pierwszy zgodny z dozwolonymi formatami graficznymi.


Operacje finansowe
( bank, kasa i kompensaty )

Pełne i rzetelne ewidencjonowanie operacji finansowych przynosi szereg korzyści.
Począwszy od wyciągów bankowych, uzyskamy kontrolę banku ( to nie żart ) oraz własnych finansów. Każda pozycja wyciągu może być skojarzona z dokumentem transakcji handlowej i poprzez to automatycznie wpłynie na kwotę należności lub zobowiązań. Skończywszy na kompensatach, umożliwiających bezgotówkowe rozliczanie między kontrahentami.

Kilka uwag.
Okienko składa się z dwóch tabelek zawierających nagłówki dokumentów i ich specyfikacje. Jeśli wpisujemy wyciąg bankowy, to w nagłówku powinien występować bank jako kontrahent. Jeśli wpisujemy raport kasowy, to w nagłówku powinna wystąpić kasa firmy i najczęściej wystarczy wybrać "siebie" z listy kontrahentów. Podobnie wygląda sytuacja podczas wpisywania kompensaty, kiedy to musimy w nagłówku wskazać swojego kontrahenta.
Jak widać, w każdym przypadku można wybrać dowolnego kontrahenta i tylko od Ciebie zależy, czy zapisy będą poprawne.
Nasuwa się pytanie, co zrobić w przypadku występowania kilku kas w firmie ?
Wówczas trzeba wprowadzić dodatkowego kontrahenta o nazwie np. "Moja firma - kasa dolarowa" i wybierać tego kontrahenta w nagłówku raportu kasowego.
Użytkownicy będący na pełnej rachunkowości mogą wykorzystać mechanizm auto-dekretacji. Skuteczność działania tego mechanizmu zależy od przypisania domyślnych kont w bazie kontrahentów.

Skojarzenie płatności z dokumentem można usunąć ustawiając kursor w kolumnie "Dokument" i wybranie z menu kontekstowego ( prawy myszy ) opcji "Usuń" ( lub też za pomocą klawisza [Del] ). Jeżeli pozycja specyfikacji nie posiada przydzielonego kontrahenta, to wybór dokumentu do skojarzenia polega na wyborze dokumentu jeszcze nierozliczonego. Uznaje się, że dokument nierozliczony, to taki, który ma termin płatności i nie został w pełni zapłacony.

W opcji "Kasa" istnieje możliwość wydrukowania dokumentów KP i KW. Wystarczy będąc w specyfikacji zaznaczyć pozycję i z menu kontekstowego wybrać "Drukuj" ( ewentualnie klawisz F9 ). Chciałbym zwrócić jeszcze uwagę na kolumnę Numer Transakcji Kasowej (NTK), która powinna zawierać numer dokumentu KP lub KW. Jeżeli wystąpi kilka pozycji z tym samym numerem i kontrahentem, to program w dokumencie KP/KW wydrukuje wszystkie te pozycje.


Noty odsetkowe


Środki Trwałe

Na pierwszy rzut oka widać, że ewidencja środków trwałych została maksymalnie uproszczona.

Okienko składa się z dwóch tabelek, wykazu środków trwałych i ewidencji odpisów amortyzacyjnych.
Zapewne największe zainteresowanie wzbudza ta druga, która może być wypełniana ręcznie lub automatycznie.
W tym miejscu wypada zaproponować samodzielne sprawdzenie działania automatu.

Przed zapisem do środków trwałych trzeba zaksięgować sam zakup. Jeżeli wartość netto zakupu przekracza 3500 zł, to księgujemy fakturę VAT do rejestru VAT zakupu z kategorią C oraz do Księgi Dokumentów z kategorią wyłączającą z kosztów np. Q, U. Wówczas kwota podatku VAT zostanie właściwie przeniesiona do VAT-7 i nie powielimy kosztów, bo po rozpoczęciu amortyzacji kosztem będą odpisy. Jeżeli wartość zakupu jest niższa niż 3500, to należy podjąć decyzję o ewentualnym wprowadzeniu na wyposażenie.

Ogólnie mamy następujące rozwiązania:

1. środki trwałe - wartość powyżej 3500
ewidencja środków trwałych metodami:
- metody liniowej
- metody degresywnej
- metody dowolnej innej
- zmianę wartości środka
 w efekcie automatycznie generuje Notę z odpisami amortyzacyjnymi

2. wyposażenie - wartość poniżej 3500 i ( większa od 1500 lub użytkowanie dłuższe od roku )
- wypełniamy specyfikację faktury zakupy ze wskazaniem magazynu "Wyposażenie"
3. koszt jednorazowy - mniejsza od 1500 i użytkowanie krótsze od roku
- wystarczy uproszczone księgowanie faktury
4. leasing operacyjny - amortyzacja na pełnej rachunkowości
- dochodzi odpowiednia dekretacja faktury czynszowej


Magazyn

Stan magazynu kształtuje się zgodnie z dokumentami zakupu i sprzedaży. Procedura weryfikacji sumuje zakupiony i sprzedany towar w/g dokumentów.


Ewidencja przebiegu pojazdów

Ewidencja Przebiegu i Kosztów Pojazdu prywatnego do celów służbowych.

Efektem końcowym ewidencji jest rozliczenie kosztów eksploatacji zgodnie z obowiązującymi przepisami.
Rozliczenie to polega na zaksięgowaniu uzasadnionych kosztów do Księgi Dokumentów i podatku VAT do Rejestru VAT zakupów.

W skład ewidencji wchodzą dwa wykazy:
1. dowodów księgowych - dokumentujących wydatki
2. przebiegu, tzw. kilometrówka

Na podstawie obu wykazów program wykonuje podsumowania i zestawienie miesięczne kosztów z uwzględnieniem ewentualnego przeniesienia nadwyżek.

Przeniesienie dokumentów odbywa się podczas operacji sumowania i jest wykonywane pod warunkiem, że data dokumentu jest większa od stałej programu ( menu System->Stałe programów->VATowiec) o nazwie "Od kiedy autoprzenoszenie Ewid. Przebiegu".

Reguły przeniesienia do Rejestru VAT:
1. data dokumentu większa od stałej programu
2. zaznaczone pole "VAT do odliczenia"

Reguły przeniesienia do Księgi Dokumentów
1. data dokumentu większa od stałej programu
2. data księgowania do KD w/g poniższej metody

Metoda księgowania kosztów.
Podczas operacji sumowania program:
- sumuje koszty wynikające z przebiegu i kwotę z przeniesienia z poprzedniego miesiąca
- sumuje koszty udokumentowane w danym miesiącu i kwotę z przeniesienia:
jeżeli różnica pierwszej sumy i drugiej jest:
a) większa od zera, to dokument jest księgowany w danym miesiącu
b) mniejsza od zera, to dokument jest księgowany w następnym miesiącu

Przypadek szczególny dotyczy braku możliwości zaksięgowania kosztów, gdy koszty wyliczeniowe na podstawie przebiegu są zbyt niskie. Należy bowiem pamiętać o zasadzie księgowania kosztów w miesiącu bieżącym lub następnym. Jeśli zatem występuje sytuacja, że posiadamy zbyt duże koszty udokumentowane, to należy rozważyć możliwość kwotowego podziału dokumentu na kilka np. typu Dowód Wewnętrzny.


Zamówienia

Działanie w kierunku poprawy płynności towarowej można sprowadzić do właściwego systemu zamówień.


Dokumenty seryjne

Wiele firm spotyka się z księgowaniem transakcji wielokrotnych i zaliczają się do nich głównie usługi.
Dzięki wykorzystaniu dokumentów seryjnych można zaoszczędzić bardzo dużo czasu i co jest bardzo ważne, zautomatyzować symulację przychodów i kosztów.


Kontrahent

Metoda ewidencji kontrahentów wzbudza zawsze wiele sprzeciwów i każdy użytkownik chciałby wprowadzić własną koncepcję. Niestety nie ma w tym zakresie kompromisów i chyba zawsze jest źle.

Oto jedna z wielu propozycji, która została wypracowana wieloletnimi doświadczeniami uzyskanymi w VATowcu dla DOS oraz porównaniu z innymi programami.

- dane wszyskich kontrahentów, urzędów, banków, kas są przechowywane w jednej tabeli
- dostawca i klient są zapisywani jako dwie pozycje, nawet wtedy, gdy to jest ten sam kontrahent
- program sprawdza wszystkie istotne dane kontrahenta, w tym numery identyfikacyjne NIP, PESEL, REGON
- każdy kontrahent musi mieć wpisaną nazwę skróconą
- pozycje tabeli nie są numerowane tj. nie ma kodu kontrahenta

Od czego zacząć ?
1. uzupełnij dane swojej firmy w domyślej pozycji "Moja firma" ( w tym bardzo ważną Formę Działalności )
2. uzupełnij dane Urzędów Skarbowych, ZUS i banku
3. nie musisz wpisywać wszystkich swoich kontrahentów

Na co zwrócić uwagę ?
1. na poprawność zapisu NIP
2. na właściwe przypisanie typu kontrahenta: D - dostawca, K - klient, ...

Dzięki poleceniom Eksport i Import w menu podręcznym ( prawy klawisz myszy ) można zapisać dane kontrahentów do pliku, który można przesłać do innej lokalizacji ( oddziału, centrali, biura, firmy ... ), a następnie wczytać dane z pliku do bazy kontrahentów.


Katalog Towarów i Usług

Uniwersalność zastosowań programu wymaga konieczność zastosowania dwóch sposobów wyboru przedmiotów transakcji hadlowej, tj. wyboru z katalogu i z magazynu. Katalog jest bardzo ogólnym pojęciem i w praktyce powinien zawierać wszystkie towary i usługi, włącznie z zakupionymi na własne potrzeby.

Dzięki poleceniom Eksport i Import w menu podręcznym ( prawy klawisz myszy ) można zapisać pozycje katalogu do pliku, który można przesłać do innej lokalizacji ( oddziału, centrali, biura, firmy ... ), a następnie wczytać dane z pliku do katalogu towarów i usług.


Magazyny

Podział przechowywanego towaru na kilka magazynów jest uzasadniony lokalizacją i przepisami branżowymi.
Program umożliwia prowadzenie około 20 magazynów, nadając każdemu jednoliterowy kod.
Dwa z tych magazynów są z góry zastrzeżone na magazyn główny i wyposażenie.


Plan Kont

Okienko zawiera dane dotyczące planu kont, czyli numer konta, nazwę i typ oraz dane dotyczące bilansu.
Do najważniejszych cech należy zaliczyć możliwość przeglądania danych dla dowolnie wybranego roku księgowego.

Weryfikacja zapisów do bilansu
Operacja wykonuje zerowanie bilansu, a następnie powtórne księgowanie na podstawie danych zawartych w rejestrze księgowań, czyli rejestrze dekretów. Bazą wykonania operacji są wszystkie dekrety oznaczone jako zaksięgowane. Jeśli zatem zmienisz jakąś istotną informację dekretu np. kwotę, to trzeba wykonać weryfikację. Jeśli zmienisz definicję autosumy, to również należy wykonać weryfikację choć w rejestrze nie występują dekrety dotyczące autosumy.


Potwierdzenia sald

Obowiązek wydrukowania i wysłania potwierdzenia salda do swojego kontrahenta spoczywa na wszyskich podmiotach gospodarczych będących na pełnej księgowości.


Podatek dochodowy

Obliczenie podatku dochodowego wymaga zebrania danych dotyczących przychodów i kosztów od początku roku. Operacja ta jest przeprowadzana w czasie sumowania uruchomionego w Księdze Dokumentów. W zależności od formy działaności gospodarczej występują różne sposoby obliczenia podatku od dochodu. Upraszczając nieco opis założymy, że podatnikiem jest osoba fizyczna. Wówczas obliczenie podatku dochodowego wymaga zastosowania progów podatkowych wpisywanych do stałych miesięcznych w menu "Słowniki->Stałe". Chcąc dalej obliczyć zaliczkę należy odjąć kwotę już zapłaconą oraz kwotę zapłaconych sładek na ubezpieczenie zdrowotne. Jak widać istnieje potrzeba określenia składek zdrowotnych i to jest robione na postawie zapisów do Księgi Dokumentów. Wskazanym rozwiązaniem jest księgowanie składek ZUS jednym dokumentem DW z rozróżnieniem kategorii księgi, na K (pozostałe koszty) obejmując składki emerytalne i rentowe oraz O - zawierającej kwotę składki zdrowotnej i odejmowanej od podatku.

Program rozróżnia firmę po danych zapisanych w wykazie kontrahentów, a dokładniej informacji w polu Forma Działaności.

Eksport do formularzy IPS dotyczy symboli "PIT5_", "CIT2_,P" ( w zależności od formy działalności), "USP,P", co oznacza, że zostaną wywołane wszystkie aktualne formularze, których symbol zaczyna się odpowiednio znakami PIT5_, CIT2_ i USP.

Uwaga !
Po zmianie w polu "blokada podatku" trzeba otworzyć okno Księgi Dokumentów i uruchomić "Sumowanie", żeby program mógł policzyć od nowa wszystkie dane zawarte w tej tabeli, a szczególnie zaliczki na podatek dochodowy. Warto pamiętać, że wszystkie dane w zestawieniu są uzupełniane pod sumowania. Zasada ta jest róznież stosowana w przypadku podatku VAT i rejestrów.


Podatek VAT

Podobnie jak w przypadku obliczania podatku dochodowego, podatek VAT jest obliczany na podstawie danych zawartych w Rejestrach VAT po uruchomieniu sumowania. Wielkość podatku zależy od danych w rejestrach, zatem tylko tam możesz wykonać odpowiednią korektę w razie niezgodności.

Wszystkie dane tabeli począwszy od następnego miesiąca są wynikiem symulacji finansowej.

Podczas obliczania podatku program uznaje, że został zapłacony lub otrzymano zwrot dopiero po wpisaniu kwoty.
Kwota dodatnia mówi o zapłaceniu podatku, a kwota ujemna o jego zwrocie.

W celu rozróżnienia metody miesięcznej i kwartalnej należy wpisaywać datę zapłaty.
Jeżeli zostanie wpisana data zapłaty w metodzie miesięcznej, to program uzna, że podatnik rozlicza się w skali miesiąca, a w przeciwnym wypadku, tj. jeśli zostanie wpisana data zapłaty w metodzie kwartalnej, to program uzna, że podatnik rozlicza się kwartalnie.
Następstwem takiego postępowania będzie automatyczne uzupełnienie kwot zapłaconych dla metody przeciwnej.

Ze względu na wymagane zaokrąglenia wystapi zawsze niewielka różnica kwot w obu metodach.

Eksport do formularzy IPS dotyczy symboli "VAT7_","VAT7K_","USP,V", co oznacza, że zostaną wywołane wszystkie aktualne formularze, których symbol zaczyna się znakami VAT7_ , VAT7K_ i USP, ale oba formularze VAT7 są wybierane kontekstowo w zależności od sposobu rozliczania VAT.


Symulacja finansowa

Mechanizm symulacji jest bardzo przydatny do prowadzenia gospodarki finansami.
Program wspiera w realizacji tego zadania na kilku poziomach:
- przyszłe zakupy i sprzedaż w Rejestrze VAT
- przyszłe przychody i koszty w Księdze Dokumentów
- przyszłe odpisy amortyzacyjne

Przeprowadzenie symulacji polega na wprowadzeniu dokumentów do Rejestrów i Księgi w/g następującego algorytmu:
1. nowy dokument
2. nie poprawiaj daty, pozostawiając znaki "??" w polu daty
3. kwota transakcji
4. "sumuj" - tą operację można wykonać na końcu

Efektem symulacji są uzupełnione sumy miesięczne oraz tabele podatków.

W przypadku środków trwałych wystarczy włączenie automatu wyliczającego odpisy.


tabela ADEKRET

Tabela ADEKRET.dbf - automatyczne dekrety

ROK | - rok autodekretu
KONTO_FK | - konto księgowe, z którego ma działać automatyczny dekret
STR | - strona konta: "W" - winien, "M" - ma oraz "X" - dla obu stron
KONTO_FK1 | - konto docelowe
STR1 | - strona konta docelowego
KONTO_FK2 | - konto przeciwstawne


pole ADEKRET->ROK

ROK
obowiązywania automatycznego dekretu.
Wprowadzenie "roku" jest związane z częstą zmianą znaczenia kont rozbudowanego rachunku kosztów, zaczynających się na 4 i 5.


tabela ASUMD

Tabela ASUMD.dbf - automatyczne sumy - konta docelowe/definicje

ROK | - rok autosumy
KONTO_FK | - nr konta docelowego - zapisu sumy
OPIS | - opis zdefiniowanej sumy


pole ASUMD->ROK

ROK
auto sumy.
Co roku ulega zmianie plan kont, a przedewszytkim konta składające się na wynik finansowy.


tabela ASUMS

Tabela ASUMS.dbf - składniki autosum

ZN | - znacznik autosumy
KONTO_FK | - nr konta składnika
STR | - strona konta składnika


pole ASUMS->ZN

ZN
- znak autosumy
Najczęściej wystarczy zostawić pole puste lub wpisać znak "+", co jest tożsame.
Ponieważ istnieją przypadki sumowania ze znakiem przeciwnym niezależnie od strony konta, wprowadzono możliwość zastosowania znaku "-" i wówczas nastąpi po prostu odejmowanie.


Automatyczne dekrety
Ten mechanizm wprowadzono w celu skrócenia czasu księgowania.
Często istnieje konieczność księgowania określonych kwot na dwa (lub więcej) konta rozrachunków, lub też kilka kont kosztów. W praktyce automatyczne dekrety są wręcz wymagane w rozbudowanym rachunku kosztów.

Automatyczne dekrety są stosowane w przypadku księgowania na inne znane konta oprócz domyślnych. Najczęściej istnieje potrzeba zastosowania automatycznego dekretu w rozbudowanym rachunku kosztów.

Przykład z życia:
Pan X kupuje paliwo za swoje pieniądze na stacji benzynowej Y. Normale księgowanie powinno wyglądać tak:
brutto -> konto stacji MA
netto -> konto kosztów WN
VAT -> konto VAT WN
ale ponieważ zapłacił Pan X, to wpisujemy dekret:
brutto -> rozrachunki z pracownikami WN
brutto -> konto Pana X MA
i wówczas w automatycznych dekretach trzeba wpisać:
konto stacji MA -> rozrachunki z prac. WN i konto Pana X MA

Automatyczne dekrety uruchamiają się w czasie zapisu dekretów do rejestru księgowań pod warunkiem, że są poprawnie zdefiniowane. Należy pamiętać o bardzo ważnym fakcie księgowania przeciwstawnego. Inaczej mówiąc zawsze suma kwot stronami musi dać zero.
UWAGA ! Program "pilnuje" zgodności automatycznych dekretów pod warunkami: nie są jeszcze zaksięgowane i nie wykonano zmiany konta dekretowanego. Jeśli dekretacja odbywa się w sposób płynny, program wykona automatycznie korekty autodekretów.


Automatyczne sumy
Wieloletni plan kont i bilans posiadają wiele zalet, między innymi brak zamknięć miesięcy i lat.
Program jest na tyle wyjątkowy, że zapewnia ciągłą pracę bez zbędnych czynności wszechobecnych w innych programach.
Kończąc samozachwyt :-) przejdę do możliwości zastosowania autosum.

Wszystkie księgowania wykonane po zdefiniowaniu (zmiany) autosumy są automatycznie przeksięgowywane.
Mechanizm nie działa dla dekretów już zaksięgowych i w celu aktualizacji bilansu trzeba wykonać weryfikację zapisu do bilansu.

Na podstawie powyższych informacji można przeprowadzić definiowanie:

czas definiowania | wymagania
1. przed rozpoczęciem roku 2. w trakcie roku księgowego 3. po zakończeniu roku księgowego | - pełna znajomość planu kont - weryfikacja - weryfikacja


Dekretacja

Księgowanie dokumentu w pełnej rachunkowości polega na przeniesieniu odpowiednich kwot do planu kont. Przeniesienie to musi spełniać jedną podstawową zasadę, a mianowicie: suma kwot po stronie winien musi być równa sumie kwot po stronie ma. Księgując zatem jakąś kwotę na rozrachunki z kontrahentem, trzeba również zaksięgować tą kwotę na np. koszty, sprzedaż, itp.

Podstawową operacją podczas księgowania jest utworzenie dekretu, tj. opisu zawierającego konto, datę i kwotę. W celu przyśpieszenia pracy w programie wprowadzono automatyczną dekretację, która polega na tworzeniu dekretów przez program na podstawie informacji o domyślnych kontach, zdefiniowanych np. w tabeli kontrahentów. Kolejnym elementem automatyzacji jest tworzenie dekretów zdefiniowanych w tabeli automatycznych dekretów, menu FK->Auto dekrety.

Wszystkie transakcje wykonywanywane w walucie obcej trzeba przewalutować do waluty księgowej. Dekretacja umożliwia zaksięgowanie do planu kont kwot w obu walutach.

Nowy dekret dodajemy na kilka sposobów:
1. dzięki zastosowaniu wymienionych automatów
2. za pomocą opcji menu podręcznego ( prawy klawisz myszy )
3. po naciśnięciu klawisza [Ins]

Usuwamy dekret stosując:
1. menu podręczne i opcja "Usuń"
2. klawisz [Del]

W tabeli znajduje się dodatkowa kolumna "poz." zawierająca identyfikator dekretu. W przypadku wyciągów bankowych, raportów kasowych i kompensat, identyfikator ten wiąże dekret z pozycją specyfikacji dokumentu.
Zaleca się, aby nie zmieniać danych w tej kolumnie i możliwość edycji traktować jako rozwiązanie awaryjne.

Uwaga:
Jeżeli został usunięty dekret zaksięgowany, to należy bezwzględnie uruchomić "Weryfikację" w planie kont !


tabela DK

Tabela DK.dbf - kontrahenci, urzędy, banki

NAZWA_SKR | -nazwa identyfikująca, nie jest drukowana i może być któtką nazwą handlową
NIP | -identyfikacja podatkowa
PESEL | -"numer obywatela"
REGON | -ewidencja GUS
FD | -czy OF (osoba fizyczna), czy też jakaś spółka np. SA (akcyjna)
WLASCICIEL | -firmy
TDK | -typ kontrahenta: K-klient, D-dostawca, U-urzęd, ...
PRZEDMIOT | -domyślny przedmiot transakcji
DT_DATA | -data wydania Dowodu Tożsamości
DT_NR | -nr Dowodu
DT_WYD | -kto wydał DT ?
KONTO | -bieżące konto bankowe
BANK | -bieżący bank
RABAT | -domyślny rabat transakcji
TERMIN | -domyślny termin zapłaty
ZAPLATA | - forma zapłaty


pole DK->BANK

Nazwa banku, w którym kontrahent ma swoje aktualne konto gospodarcze.


pole DK->DT_DATA

Data wydania Dowodu Tożsamości.


pole DK->DT_NR

Numer dowodu tożsamości


pole DK->DT_WYD

Przez kogo został wydany Dowód Tożsamości


pole DK->FD

Forma działalności
Określenie formy jest szczególnie istotne dla opisu Twojej Firmy.
Na podstawie tej informacji program np. stosuje odpowiedni algorytm obliczania podatku dochodowego oraz pobiera właściwe dane do wydruków i formularzy. Wpisz "OF" jeśli prowadzisz działalność gospodarczą jako osoba fizyczna i analogicznie "SC", "SJ",..."SA" dla spółek.


pole DK->KONTO

Pełny numer konta bankowego kontrahenta.

Dopuszcza się stosowanie dowolnego formatu numeru konta bankowego.


pole DK->NAZWA_SKR

Skrócona nazwa kontrahenta ( urzędu, banku, ...) funkcjonuje wyłącznie w programie.
Często stosuje się nazwę hadlową lub po prostu skrót.

Nazwę skróconą możesz zmieniać w dowolnym momencie i nie rzutuje to na nic.


pole DK->NIP

Numer Identyfikacji Podatkowe musi być wpisywany bezwzględnie poprawnie. Program kontroluje poprawność NIP zgodnie z algorytmem wagowym. W przypadku stwierdzenia błędu, NIP zostanie uzupełniony znakiem "?". Jeśli koniecznie chcesz wpisać NIP w innym formacie niż ogólnie przyjęty, tj. 3-3-2-2, to zmień stałą programów wyłączając wymuszony format.


pole DK->PESEL

Numer identyfikacji PESEL jest niezbędny w przypadku wykonywania transakcji handlowych z np. rolnikami.


pole DK->PRZEDMIOT

Domyślny przedmiot transakcji

Informacja ta jest wykorzystywana podczas tworzenia nowego dokumentu.


pole DK->RABAT

Domyślny rabat


pole DK->REGON

Numer identyfikacji statystycznej REGON.

Informacja ta nie jest wymagana.


pole DK->TDK

Typ kontrahenta: D - dostawca, K - klient, B - bank, U - urząd itd.

Wpisując typ "kontrahenta" ułatwisz sobie pracę w przyszłości,
bowiem program domyślnie ustawia wybór kontrahenta w zależności od sytuacji.


pole DK->TERMIN

Domyślny termin zapłaty w dniach od daty sprzedaży.


pole DK->WLASCICIEL

Właściciel firmy, pole informacyjne.


pole DK->ZAPLATA

Domyślna forma zapłaty.

Informacja jest wykorzystywana w Księdze Dokumentów.


Dokumenty seryjne - harmonogram

Jest to efekt działania polecenia "Aktualizuj"
Wówczas też są tworzone dokumenty w Rejestrze VAT i Księdze Dokumentów.


Dokumenty seryjne - specyfikacja

Specyfikacja dokumentu seryjnego jest wzorcem, który będzie powielany podczas aktualizacji.


Dziennik chronologiczny
stanowi wykaz wszystkich księgowań przeprowadzonych w danym okresie.
Do obowiązku należy wykonywanie wydruku dziennika lub przechowywanie danych w formie elektronicznej na trwałych nośnikach.

Wydruk możesz wykonać z menu kontekstowego (prawy klawisz myszy) lub za pomocą F9.

Wszystkie okresy miesięczne posiadają odrębną ewidencję sum, która jest uaktualniania po wykonaniu wydruku.
Jeżeli zatem uległy zmianie dane z określonego miesiąca, to należy wykonać wszystkie wydruki począwszy od tego miesiąca.


tabela FORSA

Tabela FORSA.dbf - operacje finansowe

DATA | - wyciągu, raportu lub kompensaty
NR | - numer kolejny
SALDO | - saldo początkowe


pole FORSA->DATA

Data dokumentu finansowego.


pole FORSA->NR

Numer dokumentu finansowego (wyciągu, raportu)


pole FORSA->SALDO

Saldo początkowe dokumentu


tabela FORSAP

Tabela FORSAP.dbf

LP | - liczba porządkowa
OPIS | - krótki opis operacji
KWOTA_WN | - przychód
KWOTA_MA | - rozchód
KWOTA | - kwota transakcji w walucie dokumentu


pole FORSAP->KWOTA

Kwota dokumentu, czyli zgodna pod względem waluty.
Jeżeli występuje inny waluta w nagłówku dokumentu, to kwota ta nie jest automatycznie wyliczana na podstawie przychodu i rozchodu.


pole FORSAP->KWOTA_MA

Rozchód - kwota pobrana.


pole FORSAP->KWOTA_WN

Przychód - kwota zasilenia


pole FORSAP->LP

Liczba porządkowa jest wypełniana półautomatycznie.
Program próbuje pomóc w prawidłowym wypełnieniu tego pola.

Liczba porządkowa nie musi odpowiadać pozycji na dokumencie źródłowym.
Biorąc na przykład pod uwagę spłatę kilku dokumentów transakcji handlowej z tym samym kontrahentem, możesz rozpisać jedną pozycję np. wyciągu bankowego na kilka i w ten sposób przypisać wszystkie dokumenty.


pole FORSAP->OPIS

Krótka notatka o transakcji.


Historia towaru

Historia towaru umożliwia sprawdzenie dokumumentów zakupu i sprzedaży.


Kalkulator odsetkowy


Kategorie KD

Kategorie księgi dokumentów

Kategoria przypisana do kwoty w KD wskazuje na rodzaj wydatku lub przychodu.
Na szczególną uwagę zasługuje kolumna z określeniem przychodu, kosztu lub wskazaniem odjęcia od podatku.
Tam trzeba odpowiednio wpisać "P", "K" lub "O". Jeżeli nie zostaną uzupełnione te dane, to program nie będzie sumował wartości przychodów i kosztów
do rozliczenia z US, a zatem nie będzie również obliczał podatku.

Kolumna konto powinna zawierać domyślne konto FK, na które mają być księgowane kwoty.


Kategorie rejestru VAT

Wprowadzenie kategorii uprościło strukturę tabel i zwięszyło możliwość konfiguracyjne programu.

Za kategorię rozumiemy sposób księgowania dokumentów w rejestrze VAT. Kategoria wskazuje rodzaj sprzedaży/zakupu, rodzaj dokumentu lub typ operacji.

W związku z wprowadzeniem pojęcia kategorii istnieje możliwość dowolnego definiowania celu i postaci wykonanej sprzedaży.
Litera występująca w pierwszej kolumnie, odpowiada literze występującej w stopce VAT rejestru.


tabela KPIR

Tabela KD.dbf

LP | liczba porządkowa
DATA | data księgowania
RD | rodzaj dokumentu
NDK | numer dokumentu księgowego
OPIS_ZG | opis zdarzenia gospodarczego
KWOTA | wartość odpowiadająca kwocie dokumentu
TERMIN | data uregulowania płatności
DO_ZAPLATY | kwota do zapłaty
D_ZAPLATY | data faktycznej zapłaty
PK | nr polecenia księgowania


pole KD->D_ZAPLATY

Data zapłaty


pole KD->DATA

Data księgowania


pole KD->DO_ZAPLATY

Do zapłaty


pole KD->KWOTA

Kwota z dokumentu ksiegowego


pole KD->NDK

Numer dokumentu księgowego

Pole posiada miejsce na 16 znaków dowolnego tekstu. Oznacza to, iż czasem wystąpi konieczność skrócenia np. numeru faktury, który jest zbyt długi. Niestety są jeszcze firmy obdarzone poczuciem artystycznej twórczości i produkują np. 2002/oszc/mg16/lk/0000015
Jak widać, numer ten zawiera szereg informacji zbędnych i można, z zachowaniem zasady jednoznaczności, usunąć lub skrócić rok, oddział, nr magazynu, zera, znaki "/" itd.
Postępowanie to jest zgodne z prawem.


pole KD->OPIS_ZG

Opis zdarzenia gospodarczego
wystąpi na wydruku, dlatego też powinien krótko charakteryzować zaistniałe zdarzenie gospodarcze.


pole KD->PK

Nr polecenia księgowania


pole KD->RD

Rodzaj dokumentu księgowego

Jest to pole zawierające dwuliterowy skót określający jednoznacznie rodzaj dokumentu. Zaleca się stosowanie następujących skrótów:
FA - faktura VAT
KO - korekta VAT
PW - przychód wewnętrzny
RW - rozchód wewnętrzny
DW - dowód wewnętrzny
WB - wyciąg bankowy
RK - raport kasowy
PK - polecenie księgowania
NT - nota
NO - nota odsetkowa

Program przenosząc dokumenty do Księgi nadaje rodzaj dokumentu zgodnie z powyższym wykazem.


pole KD->TERMIN

Termin zapłaty.

Wpisanie tej daty jest warunkiem koniecznym do przeniesienia dokumentu do terminarza należności i zobowiązań.


Klasyfikacja Środków Trwałych

Wykaz ten wprowadzono jako pomocniczy ponieważ nie wpływa na wyliczanie kwot odpisów amortyzacyjnych. Jego znaczenie ma charakter porządkowy i wykorzystuje się opis grupy środków trwałych w wydrukach.


tabela KNTBNK

Tabela KNTBNK.dbf

DATA_WAZ | data ważności konta
KONTO | pełny numer konta bankowego


pole KNTBNK->DATA_WAZ

Data ważności konta


pole KNTBNK->KONTO

Konto bankowe kontrahenta


Konta bankowe

Konta bankowe kontrahentów

Każdy kontrahent może mieć przypisanych wiele kont bankowych,
a jedno z nich ustalone jako bieżące.
W polu konta trzeba wpisać pełny numer konta tj. łącznie z nr kierunkowym banku.


tabela KP

Tabela KP.dbf

KWOTA dla określonej kategorii księgi


pole KP->KWOTA

Kwota z dokumentu ksiegowego dla określonej kategorii kosztu lub przychodu.


tabela KPK

Tabela KPK.dbf

KAT_KP | kategoria - duża litera alfabetu łacińskiego
DRUK | opis na wydruku
OPIS | krótko o celu
KP | koszt, czy przychód


pole KPK->DRUK

Opis na wydruku jest najczęściej stosowany jako treść nagłówka tabeli


pole KPK->KAT_KP

Kategoria, jednoliterowy symbol.


pole KPK->KP

koszt, czy przychód


pole KPK->OPIS

treść wskazująca przeznaczenie kategorii


tabela KTLG

Tabela KTLG.dbf

SV | stawka VAT
MARZA | marża sprzedaży
IL_STAN | aktualny stan ilościowy
KTU | kategotria pozycji katalogu: Towar, Usługa, ...
KAT_RV | domyślna kategoria rejestru VAT


pole KTLG->IL_STAN

Stan ilościowy


pole KTLG->KAT_RV

Kategoria rejestru VAT


pole KTLG->KTU

Kategoria katalogu

Jest to jednoliterowe określenie pozycji jako Towar lub Usługa, które rozpoznaje program.


pole KTLG->MARZA

Marża


pole KTLG->SV

Domyślna stawka VAT


Log zmian


Wydruk remanentu

Wydruk można wykonać na dowolnie wybrany dzień i z dowolnie wybranych magazynów.
Jeżeli wybrany dzień jest inny niż dzisiejszy i ostatnio nie wykonywano wydruku na ten dzień, to program przeliczy stan magazynu według dokumentów zakupu, sprzedaży, przychodu i rozchodu magazynowego.

Format wydruku zależy od wybranych opcji i stałych programów.
Trzeba zwrócić uwagę na stałe menu System->Stałe programów: "Cyfry dziesiętne w ilości towaru" oraz "Czy magazyn od NETTO ?"


tabela MGR

Tabela MGR.dbf

NAZWA | nazwa towaru
CEN | cena ewidencyjna netto
MARZA | domyślna marża sprzedaży
CSN | cena sprzedaży netto
IL_STAN | stan ilościowy na magazynie
WEN | wartość ewidencyjna netto
WSN | wartość sprzedaży netto


pole MGR->CEN

Cena ewidencyjna netto


pole MGR->CEN

Cena sprzedaży netto


pole MGR->IL_STAN

Stan ilościowy


pole MGR->MARZA

Marża


pole MGR->NAZWA

Nazwa towaru


pole MGR->WEN

Wartość ewidencyjna


pole MGR->WSN

Wartość sprzedaży


tabela MGS

Tabela MGS.dbf - wykaz magazynów

KOD_MG | kod magazynu
NAZWA | nazwa magazynu


pole MGS->KOD_MG

kod magazynu


pole MGS->NAZWA

nazwa magazynu


tabela NOP

Tabela NOP.dbf - noty odsetkowe - pozycje

KWOTA | kwota do naliczenia odsetek
D_ZAPLATY | data zapłaty
ODSETKI | naliczone odsetki


pole NOP->D_ZAPLATY

Data zapłaty


pole NOP->KWOTA

Kwota pozycji noty odsetkowej


pole NOP->ODSETKI

Odsetki


Notatka

jest to tekst przypisany do wskazanego dokumentu. Występują dwa rodzaje notatek, nie drukowana i drukowana. Jeżeli chcesz opisać dokument do własnych potrzeb, to wpisz tekst do notatki nie drukowanej, jeśli chcesz, aby pojawiła się na wydruku np. Faktury VAT, to wpisz tekst do notatki drukowanej. Istnieje możliwość przypisania stałego tekstu informacyjnego do drukowanego dokumentu, o czym można poczytać tutaj.


Notatka do raportu

jest to stały tekst przypisany do wybranego raportu. Notatka ta jest drukowana na wszystkich dokumentach, dla których ją zdefiniowano.


Plan Kont - dewizy

Konta dewizowe


Parametry wydruku planu kont

Parametry wydruku plan kont


wybór konta

Wybór konta FK z plan kont

Okienko zawiera dane dotyczące planu kont, czyli numer konta, nazwę i typ oraz dane dotyczące bilansu.
Do najważniejszych cech należy zaliczyć możliwość przeglądania danych dla dowolnie wybranego roku księgowego.


zmiana konto BO

Zmiana konta bilansu otwarcia

Jak już wiadomo, program automatycznie aktualizuje bilans otwarcia następnego roku zakładając, że nr konta nie ulega zmianie.

Co zrobić, gdy musimy zmienić plan kont ?
Odp.
Wystarczy uzupełnić tabelkę o określone zmiany ?

W przeciwnym wypadku, należy poczekać do zakończenia roku księgowego i ręcznie przeksięgować wszystkie zmienione konta.

UWAGA !
Jak zwykle po istotnych zmianach przeprowadź weryfikację zapisów do bilansu z poziomu Planu Kont dla starego roku księgowego !


tabela PLN_KNT

Tabela PLN_KNT.dbf

KONTO_FK | numer konta FK
NAZWA | nazwa konta
WN00 | BO strona winien
MA00 | BO strona ma
TYP | typ konta: Analityczne, Syntetyczne


pole PLN_KNT->KONTO_FK

Numer konta FK składa się z dwóch segmentów. Pierwszy, trzycyfrowy określa znaczenie konta w/g wzorcowego planu, a drugi, pięciocyfrowy określa pozycję.


pole PLN_KNT->MA00

pole MA00 - bilans otwarcia po stronie ma


pole PLN_KNT->NAZWA

Nazwa konta


pole PLN_KNT->TYP

Typ konta:
A - analityczne - dla księgowań
S - syntetyczne - sumy kont analitycznych


pole PLN_KNT->WN00

Bilans otwarcia po stronie winien


tabela PLN_KNTD

Tabela PLN_KNTD.dbf

WALUTA | waluta subkonta
WN00 | BO po stronie winien
MA00 | BO po stronie ma
TYP | typ konta


pole PLN_KNTD->MA00

Bilans otwarcia dewiz po stronie ma


pole PLN_KNTD->TYP

Typ konta dewizowego


pole PLN_KNTD->WALUTA

Waluta konta dewizowego


pole PLN_KNTD->WN00

Bilans otwarcia konta dewizowego po stronie winien


tabela PRD

Tabela PRD.dbf - produkcja

DATA | data produkcji
NDK | numer dokumentu księgowego


pole PRD->DATA

Data produkcji


pole PRD->NDK

Numer dokumentu księgowego


Produkcja

Proces produkcji występuje zawsze podczas zmiany właściwości przedmiotu. W programie poprzez produkcję rozumiemy wytworzenie nowego produktu na podstawie składników. Wszystkie składniki będące towarem powinny być "zdejmowane" z magazynu, a gotowy produkt "wprowadzany" na magazyn. Proces produkcji rozpoczynamy od utworzenia nowej pozycji, a kończymy wypełniając specyfikację.


Rejestr księgowań


tabela RST_FK

Tabela RST_FK.dbf

DATA | data księgowania
KWOTA | kwota dekretu
STR | strona konta
WALUTA |
KURS | kurs dewiz
DEWIZY | kwota dewiz


pole RST_FK->DATA

Data księgowania dekretu


pole RST_FK->DEWIZY

Kwota dewiz dekretu


pole RST_FK->KURS

Kurs dewiz dekretu


pole RST_FK->KWOTA

Kwota dekretu


pole RST_FK->STR

Strona księgowania dekretu


pole RST_FK->WALUTA

Rodzaj waluty dekretu


tabela RV

Tabela RV.dbf

LP | Liczba porządkowa
DATA | data księgowania
RD | rodzaj dokumentu
NDK | numer dokumentu księgowego
PRZEDMIOT | opis zdarzenia gospodarczego
NETTO | kwota netto dokumentu
VAT |
BRUTTO | suma netto i VAT


pole RV->BRUTTO

Kwota brutto dokumentu.

Program umozliwia księgowanie kwot dokumentu zarówno od strony netto jak i brutto.


pole RV->DATA

Data księgowania


pole RV->NDK

Numer dokumentu księgowego

Pole posiada miejsce na 16 znaków dowolnego tekstu. Oznacza to, iż czasem wystąpi konieczność skrócenia np. numeru faktury, który jest zbyt długi. Niestety są jeszcze firmy obdarzone poczuciem artystycznej twórczości i produkują np. 2002/oszc/mg16/lk/0000015
Jak widać, numer ten zawiera szereg informacji zbędnych i można, z zachowaniem zasady jednoznaczności, usunąć lub skrócić rok, oddział, nr magazynu, zera, znaki "/" itd.
Postępowanie to jest zgodne z prawem.


pole RV->NETTO

Kwota netto


pole RV->PRZEDMIOT

Przedmiot zdarzenia gospodarczego


pole RV->RD

Rodzaj dokumentu księgowego

Jest to pole zawierające dwuliterowy skót określający jednoznacznie rodzaj dokumentu. Zaleca się stosowanie następujących skrótów:
FA - faktura VAT
KO - korekta VAT
NT - nota


pole RV->VAT

Kwota VAT

Wpisując tą kwotę możesz się spodziewać, że program będzie próbował ją poprawić w przypadku wystąpienia znacznych rozbieżności od wartości spodziewanej.


tabela RVK

Tabela RVK.dbf - kategorie RV

ZRV | znacznik rejestru VAT
KAT_RV | kategoria rejestru
OPIS | opis kategorii
DRUK | treść na wydruku
KONTO_FK | domyślne konto księgowe


pole RVK->DRUK

Treść drukowana opisu


pole RVK->KAT_RV

Kategoria RV


pole RVK->KONTO_FK

Domyślne konto księgowe.

Podczas wykonywania zapisów w rejestrze VAT są automatycznie tworzone dekrety. Jeśli w tym miejscu zdefiniujemy konto księgowe, to w rejestrze księgowań pojawią się odpowiednie dekrety.


pole RVK->OPIS

Opis kategorii Rejestru VAT


pole RVK->ZRV

Znacznik Rejestru VAT


tabela RVP

Tabela RVP.dbf - specyfikacja dokumentu

CENA | cena jednostkowa
RABAT | rabat do pozycji
SV | stawka VAT
NR_FABR | numer fabryczny
D_WAZN | data ważności


pole RVP->CENA

cena jednostkowa


pole RVP->D_WAZN

Data ważności


pole RVP->NR_FABR

numer fabryczny


pole RVP->RABAT

rabat


pole RVP->SV

stawka VAT


tabela RVV

Tabela RVV.dbf

SV stawka VAT


pole RVV->SV

Stawka VAT


Specyfikacja

Wykaz powinien zawierać przynajmniej jedną pozycję i może ona się nazywać "NIEZNANY TOWAR LUB USŁUGA".
Nie jest to bląd tylko uproszczenie, które daje większą swobodę w prowadzeniu np. rejestru VAT.
W efekcie wystarczy wpisać jedną kwotę np. netto faktury i uproszczona ewidencja jest zakończona.

Wniosek nasuwa się tylko jeden, jeśli prowadzisz magazyn(y) lub chcesz ewidencjonować szczegóły transakcji, to uzupełniaj specyfikację dokumentu, w przeciwnym wypadku możesz tą operację pominąć.

Skoro jesteśmy na etapie wypełnienia (bo czytasz dalej), to pragnę zwrócić uwagę na kilka faktów:
1. wszystkie pozycje specyfikacji są wybierane z Katalogu Towarów i Usług (KTU) lub wybranego magazynu
2. każda pozycja KTU powinna być określona, czy jest towarem, czy też usługą
3. magazyny mogą przechowywać wyłącznie towary
4. rozchód (sprzedaż) towarów magazynowych odbywa się z dostaw
5. można dowolnie zmieniać wszystkie dane dotyczące pozycji specyfikacji

Obliczanie podatku VAT dokumentu zawsze wywoływało wiele nieporozumień.
Chcąc uniknąć niezgodności wyliczonych kwot z Twoimi oczekiwaniami wprowadzono kilka metod stosowanych w praktyce:
1. ceny jednostkowe w NETTO lub BRUTTO - metodę możesz wybrać w menu "System" -> "Stałe programów"->"VATowiec":
a) Czy sprzedaż od NETTO ?
b) Czy zakupy od NETTO ?
c) Czy magazyn od NETTO ?
Jak widać, można ustalić niezależnie sposób podejścia do cen.
Należy jeszcze tylko dodać, że opcję można mieniać w dowolnej chwili.
2. Obliczanie podatku VAT dokumentu - metodę wybieramy analogicznie w "Stałych programów"
a) Czy obliczyć VAT sprzedaży w stopce ?
b) Czy obliczyć VAT zakupu w stopce ?
Wypada porównać obie metody obliczania podatku VAT.
Jeśli założymy, że mamy ustawienie standardowe, tj. "NIE", to VAT dokumentu jest sumą podatków ze wszystkich pozycji specyfikacji. W przeciwnym wypadku, VAT jest obliczany z sumy BRUTTO specyfikacji dla każdej stawki oddzielnie, a następnie sumowany w ramach stopki VAT.

Metodę nr 2 stosuje się w sprzedaży detalicznej od BRUTTO i z wykorzystaniem drukarek fiskalnych.


tabela ST

Tabela ST.dbf

NR_INW | numer inwentażowy
OPIS | opis środka trwałego
KRST | klasyfikator środka trwałego
DATA | data wprowadzenia środka trwałego
WAR_POCZ | wartość początkowa
DATA_LIK | data likwidacji środka
PRZYCZ_LIK | przyczyna likwidacji


pole ST->DATA

Data wprowadzenia na stan


pole ST->DATA_LIK

Data likwidacji środka trwałego


tabela ST_KL

Tabela ST_KL.dbf - klasyfikacja rodzajowa trwałych

KRST | kod klasyfikacji rodzajowej
STAWKA | procentowa stawka amortyzacji


pole ST_KL->KRST

Kod klasyfikacji rodzajowej środka trwałego


pole ST_KL->STAWKA

Stawka amortyzacji


pole ST->KRST

Klasyfikator środka trwałego


pole ST->NR_INW

Numer inwentażowy


pole ST->OPIS

Opis


pole ST->PRZYCZ_LIK

Przyczyna likwidacji


pole ST->WAR_POCZ

Wartość początkowa


tabela STP

Tabela STP.dbf

RM | miesiąc amortyzacji
PODSTAWA | -obliczenia odpisu amortyzacyjnego
STAWKA | -odpisu
ODPIS | -amortyzacja
WAR_POCZ | wartość przed odpisem
WAR_KONC | wartość po odpisie
ODPIS_ROK | odpisy narastająco od początku roku


pole STP->ODPIS

Odpis


pole STP->ODPIS_ROK

Odpis roczny


pole STP->PODSTAWA

Podstawa odpisu amortyzacyjnego


pole STP->RM

Miesiąc amortyzacji


pole STP->STAWKA

Stawka


pole STP->WAR_KONC

Wartość końcowa


pole STP->WAR_POCZ

Wartość początkowa


tabela TERMIN

Tabela TERMIN.dbf

TERMIN | data płatności
KONTRAH | kontrahent transakcji
OPIS | opis dokumentu
KWOTA | kwota zobowiązania lub należności
WALUTA | waluta transakcji


pole TERMIN->KWOTA

Kwota zobowiązania lub należności


pole TERMIN->OPIS

Opis dokumentu


pole TERMIN->TERMIN

Data zapłaty


Terminarz

Terminarz należności i zobowiązań

Wszystkie pozycje mogą i powinny być przenoszone automatycznie z rejestrów VAT. Jednak, żeby mogło to nastąpić musi być wpisany dokument z kwotą i terminem płatności.


Wybór dokumentu


wybór towaru


Zapłata

Wykaz dokumentów rozrachunków


Zestawienia finansowe

Po przejściu [Tab] do specyfikacji zestawienia przejdź kursorem w prawo do kolumny "reguła". Tam należy wpisać treść odpowiadającą regule (formula) "zbierania" danych z bilansu.

Składnia reguły:
s1_nr1_ms1_opr_s2_nr2_ms2

s1 i s2: stona konta np: "W","M","S" - winien,ma,saldo
nr1 i nr2: numer konta
opr: operator
ms - miesiąc obrotów

Przykład:
W21000031:W21000034 - sumuj wartości po stronach winien dla kont z zakresu od 210-00031 do 210-00034

M21000064+W21000065 - sumuj wartości ma konta 210-00064 strony MA i konta 210-00065 strony winien

w celu podsumowania wyników reguł stosuj oznaczenie strony jako "R" np. posumowanie wierszy od 1 do 5 R1:R5 i z obrotami:
W2100003105:W2100003407 - podobnie jak pierwszy przykład ale dla obrotów w miesiącach 5÷7.

Zestawienia finansowe umożliwiają bezproblemowe przygotowanie danych do raportu F01, RWK, Wyniku itd.


tabela ZF

Tabela ZF.dbf

NAZWA nazwa zestawienia


nazwa


tabela ZFR

Tabela ZFR.dbf

NR | numer wiersza/reguły
OPIS | krótki opis zestawienia
REGULA | reguła obliczania wyniku
DRK | czy drukować ?


pole ZFR->DRK

Czy drukować ?


pole ZFR->NR

Nr wiersza


pole ZFR->OPIS

Opis wiersza/reguły


pole ZFR->REGULA

Reguła


Zmiany wartości środka trwałego


Aktywni


Banki


tabela BANKI

tabela BANKI.dbf

NR_KIER | numer kierunkowy banku
NAZWA | nazwa banku na przelewie
NAZWA_CD | uzupełnienie nazwy banku
ADRES | ulica, plac, rondo ..
KOD | kod pocztowy lub tzw. zip
MIASTO | miejscowość siedziby banku
KRAJ | kraj siedziby
TEL1 | pełny numer telefonu
TEL2 |
FAX | pełny numer faksu


pole BANKI->ADRES

Adres banku


pole BANKI->FAX

Nr faksu do banku


pole BANKI->KOD

kod pocztowy


pole BANKI->KRAJ

kraj siedziby banku


pole BANKI->MIASTO

Miejscowość w adresie banku


pole BANKI->NAZWA

Nazwa banku


pole BANKI->NAZWA_CD

Ciąg dalszy nazwy banku


pole BANKI->NR_KIER

Numer kierunkowy banku


pole BANKI->TEL1

telefon banku


pole BANKI->TEL2

drugi telefon do banku


dostęp

Administratorem danych w tym okienku jest użytkownik o nazwie ADMIN.
Jeżeli wykaz użytkowników przekroczy jedną osobę, to program podczas uruchamiania będzie wyświetlał okienko logowania.


tabela DRK_IPS

FRM | formularz
OD_DNIA | od kiedy ważny
NAZWA | -formularza
EDYCJA | czy zgoda na edycję ?
OBLICZ | czy obliczać ?


pole DRK_IPS->EDYCJA

Czy edytować ?


pole DRK_IPS->FRM

Indetyfikator formularza


pole DRK_IPS->NAZWA

Nazwa


pole DRK_IPS->OBLICZ

oblicz


pole DRK_IPS->OD_DNIA

Od dnia


tabela DRK_IPSP

POLE | -formularza
FORMULA | definicja obliczania pola


pole DRK_IPSP->FORMULA

Formuła

Dodatkowe funkcje dla programu Kadrowiec:

PobierzSklPlc(<formularz>,<nr_pola_formularza>,<czy_dla_całej_firmy>,<data_początku>, <data_końca>)
ZliczSklPlc(<formularz>,<nr_pola_formularza>,<czy_dla_całej_firmy>,<data_początku>, <data_końca>)

Pierwsza zwraca sumę wartości wszystkich składników spełniających warunki, a druga liczbę składników.
Przykłady zastosowania znajdują się w bazie firmy testowej BRTEST.


pole DRK_IPSP->POLE

pole


Druki IPS

Formularze IPS
Współpraca z programem Formularze IPS polega na eksporcie wszystkich wymaganych danych oraz uruchomieniu programu "drukform.exe"
Z założenia każdemu formularzowi odpowiada jeden plik, którego nazwa jest zgodna z symbolem formularza.

Ponieważ większość formularzy została już zdefiniowana należy zwrócić uwagę na dwie sprawy.
Pierwsza z nich, to możliwość dowolnego modyfikowania definicji w/g własnych potrzeb
i ewentualne wykonanie importu domyślnej definicji formularza.
Import ten możemy wykonać usuwając starą lub niechcianą definicję, a następnie za pomocą menu
głównego lub podręcznego wywołujemy polecenie "import". Wówczas pojawi się lista formularzy do importu.
Jeżeli nie usuniemy starej definicji, to podczas importu zostaną zaktualizowane wszystkie pola formularza występujące w definicji domyślnej.

Definicje robocze formularzy znajdują się w plikach \BR\BAZY\DRK_IPS*, a definicje domyślne w \BR\PROGRAMY\HELP\DRK_IPS*.
Istnieje zatem możliwość przekopiowania odpowiednich plików z podkatalogu HELP do podkatalogu BAZY ( usuwając jdenocześnie pliki DRK_IPS.cdx i DRK_IPSP.cdx)

Druga sprawa dotyczy definiowania formuły.
Pole formuły powinno zawierać wyrażenie wskazujące na daną do pobrania lub będącą daną dla formularza.
W formule można stosować wszystkie podstawowe funkcje języka CLIPPER i VO np.

val( <tekst> ) - zwraca liczbę
str( <liczba>, <długość>, <po kropce> ) - zwraca tekst
dtoc( <data> ) - zamienia datę na tekst
iif(<warunek>,<prawda>,<fałsz>) - zwraca odpowiednio <prawda> lub <fałsz> w zależności od spełnienia <warunek>
int(<liczba>) - zaokrągla do liczby całkowitej poprzez odcięcie
round(<liczba>,<dziesiąte>) - zaokrągla matematycznie do <dziesiąte> miejsc po przecinku ( kropce)
rtrim(<tekst>) - odcięcie spacji z prawej strony tekstu
ltrim(<tekst>) - odcięcie spacji z lewej strony tekstu
itd.

- składnia typu: DK->NAZWA

to tabela DK - kontrahenci ( bardzo dawno temu byli tylko Dostawy-Klienci )

a NAZWA, to pole w tabeli

i tak:
DK->GMINA - odczyta gminę
DK->POWIAT
DK->KRAJ
DK->WOJEWODZ - województwo
DK->TEL
wszystkie pola można sprawdzić podglądając konkretną tabelę lub plik fld.dbf zawierający wszystkie potrzebne informacje wraz z opisem

- program jest odporny na błędy w formułach


Firma i właściciele

Wszystkie pola okienka umozliwiają wprowadzenie danych niezbędnych do wykonania prawidłowych wydruków i eksportów. Wśród danych teleadresowych występują pola informacyjne typu Forma Działalności. Identycznie do ewidencji kontrahentów, należy w tym polu określić swoją firmę jako np. OF - osoba fizyczna, SJ - spólka jawna, SA - spólka akcyjna itp.

Eksport do formularzy IPS dotyczy symboli "NIP","RG","VATR","VATZ", co oznacza, że zostaną wywołane wszystkie aktualne formularze, których symbol zaczyna się znakami NIP, RG, VATR i VATZ.


Import z internetu

Wszystkie stałe miesięczne i roczne oraz stopy odsetkowe można zaimportować ze strony internetowej, której adres określa się w stałych programu. Domyślnie przyjmuje się, że tą stroną jest http://pk.inet.pl/stale.htm


tabela KURSR

Tabela KURSR.dbf

RODZ | rodzaj kursu wymiany walut
OPIS | określenie banku lub nazwa
WALTAB | waluta odniesienia, najczęściej PLN
WALUTA | waluta kursu np.USD
ZRODLO | np. nazwa banku
KK | czy kurs księgowy np. dotyczy średniego NBP
KONTO_FK | konto róznic kursowych


pole KURSR->KK

Kurs księgowy ?


pole KURSR->KONTO_FK

Konto różnic kursowych


pole KURSR->OPIS

Opis kursu


pole KURSR->RODZ

Rodzaj kursu walut


pole KURSR->WALTAB

Waluta tabeli


pole KURSR->WALUTA

Waluta kursu


pole KURSR->ZRODLO

Źródło kursu


tabela KURSW

Tabela KURSW.dbf

DATA | data kursu
DATA_WAZ | ważność
KURS | wartość kursu
CECHA | potęga 10 np. 2 dla możnika 100
UWAGI | np. nr tabeli NBP


pole KURSW->CECHA

cecha kursu walut, potęga 10 mnożnika


pole KURSW->DATA

Data kursu


pole KURSW->DATA_WAZ

Data ważności


pole KURSW->KURS

Kurs


pole KURSW->UWAGI

Uwagi


Kursy walut

Kursy walut obcych
powinny być ewidencjonowane w przypadku prowadzenia transakcji w walucie obcej.

Ewidencja ta nie powinna sprawiać trudności i zwrócę uwagę na sprawę importu kursów z internetu.
Przed uruchomieniem importu należy wpisać poprawny adres do pliku z tabelą kursów walut.
Kursy średnie NBP są publikowane pod adresem http://www.nbp.pl/Kursy/KursyA.html
a kursy kupna-sprzedaży http://www.nbp.pl/Kursy/KursyC.html
Proszę zwrócić uwagę na wielkość liter występujących w adresie ponieważ większość serwerów je rozróżnia.

Istnieje również możliwość wpisania adresu nie wskazującego na plik z tabelą kursów np.
kursy celne znajdujące się pod adresem
http://www.mf.gov.pl/sluzba_celna/kursy_walut/index.php?dzial=537&id1=32214&id2=32215
( kiedyś http://www.guc.gov.pl/i.php?i=kursywalut )

Wszelkie uwagi proszę wysyłać na adres e-mail p@inet.pl


pracusie


Raporty definiowane

są sposobem na szybkie uzyskanie wybranych informacji z bazy danych programu.
Raporty podzielono na tematy, którym odpowiada określony zestaw tabel bazy danych. Przechodząc do definiowania nowego raportu należy wybrać interesujący temat, a następnie, typowo, dodać nową pozycję i wpisać nazwę raportu. Nazwa pojawi się na wydruku obok tematu. Kolejnym etapem definiowania raportu jest określenie kolumn na podstawie proponowanego zestawu znajdującego się o okienku listy. Kliknięcie na odpowiedni guzik ">" lub też "<" powoduje włącznie pola do raportu lub też wyłączenie. Tabela wykazu kolumn raportu umożliwia zmianę treści nagłówka, blokadę wydruku ( wstawiona kolumna może być użyta wyłącznie do filtra), określenie sortowania i zdefiniowanie filtrowania danych.

Filtrowanie.
Zagadnienie wyboru danych do raportu należy do najważniejszych i skuteczne ograniczanie decyduje o mozliwości wykorzystania raportu. Wprowadzono następujące operatory:
" " - brak operatora - filtr jest wyłączony

operator | pole tekstowe | pole numeryczne | pole daty
<< | dana z pola zawiera się w wartości | dana mniejsza ponad 1000 razy | data z pola o przynajmniej rok wcześniejsza
< | dana jest mniejsza w sensie alfabetu | dana mniejsza | data z pola wcześniejsza
= | teksty są sobie równe | obie równe | równe daty
# | teksty różne | obie różne | różne daty
~ | teksty podobne (zawierają się w sobie) | wartości przybliżone do 10% | przybliżone daty
> | dane większa w sensie alfabetu | dana większa | data pola późniejsza
>> | wartość zawiera się w tekście pola | dana większa ponad 1000 razy | data pola późniejsza ponad rok

Budowanie filtrów złożonych polega na składniu filtru z warunków dla wielu wybranych pól. Musimy wiedzieć, że domyślnie zakłada się spełnienie wszystkich warunków, czyli zastosowano operator logiczy "i". Jeżeli jednak istnieje potrzeba zdefiniowania filtru z zastosowaniem operator "lub", to wystarczy skorzystać z pola NF ( negacja filtru ) w nagłówku definicji raportu. Odznaczenie tego pola spowoduje wybranie danych do raportu, gdy zdefiniowany filtr nie jest spełniony.
Dalej należy skorzystać ze znanej zależności:
!( a i b) = ( !a lub !b), gdzie znakiem "!" oznaczono negację wyrażenia.

Przykładowo:
Zadanie polega na wygenerowaniu raportu sprzedaży dla dwóch klientów o nazwach skóconych: KLIENT1 i KLIENT2.
Do raportu wstawiamy dwie kolumny NAZWA_SKR i jedną z nich zaznaczamy, że ma się nie drukować. Po zdefiniowaniu pozostałych kolumn raportu pozostaje konieczność wstawienia odpowiednich warunków do filtru. Do pól zatytuowanych "Wartość" wpisujemy odpowiednio wymagane nazwy klientów oraz wybieramy operatory "#" ( różny). Następnie musimy zaznaczyć pole NF w nagłówku definicji raportu. Jak widać wygląda to wszystko nieco skomplikowanie, ale to tylko pozory.

W programie księgowym powinna być możliwość wykonania raportu zawierającego sumy kwot lub zliczenie liczby pozycji. Raporty Definiowane mają taką możliwość po zaznaczeniu opcji "ZLICZ" w nagłówku raportu. Efektem raportu zliczonego jest tabela zawierająca kolumny określone jako nagłówki wieszy ( nie polegają sumowaniu, ani zliczeniu ), które grupują dane i kolumny zawierające sumy pól numerycznych oraz zliczone pozostałe pola. Sprawdź działanie opcji zliczania drukując raport w obu jej stanach. Wówczas wszystko stanie się jasne ;)

Szczególne przypadki zastosowania raportów definiowanych wymagają zastosowania pól wyliczeniowych. Istnieje możliwość wykorzystania w tym celu kolumny "Formuła" specyfikacji raportu. W polu tym trzeba zapisać taką formułę, która umożliwi programowi pobranie i wyliczenie wymaganej wartości. Np. zapisując tabela1->pole1-tabela1->pole2 uzyskamy pole wyliczeniowe równe różnicy pól pole1 i pole2 tabeli1.
Wartość wyliczeniowa może być porównywana z wartością wpisaną zgodnie z zadanym operatorem.


Raporty definiowane - definiowanie

Definiwanie "Raportów definiowanych"

Jeżeli nie musisz tutaj zaglądać, to raczej nie zaglądaj :-)
Wszystkie dane zawarte w tabeli są bardzo ważne dla "Raportów definiowanych".
To tutaj można określić wszystkie tematy, a co za tym idzie tabele i sposób ich połączenia.

Pewien zestaw raportów ustalono jako domyślny i podlegający importowi. Jeśli zatem w wyniku zmian definicji program nie będzie wykonywał zamierzonych raportów, to można wykonać import domyślnych ustawień.

Czytasz dalej więc chcesz się dowieć co i jak można zdefiniować.
Na początek trzeba określić źródło danych do raportu definiowanego. Przykładowo, chcemy wydrukować adresy kilku firm. Określamy zatem treść tematu np. "Dane kliku firm". Następnie zaglądamy do menu System -> Zasoby -> Table i szukamy tabeli zawierającej dane firm. Nazwa tabeli ( tutaj DK ) musi być wpisana do kolumny "Tab". I to koniec definicji. Przejdź do Raportów Definiowanych i wybierz swój temat raportu ( swoją definicję ).


tabela ST_ODS

Tabela ST_ODS.dbf - stopy odsetkowe

R | rodzaj odsetek
DZN_START | od kiedy ważne
DZN_STOP | do kiedy ważne
NA_DNI | skala odsetek (dzień lub 365=rok )
STAWKA | procent odsetek
PDST_DZN | informacja dodatkowa, podstawa prawna
PDST_NR |


pole ST_ODS->DZN_START

Data początku ważności


pole ST_ODS->DZN_STOP

Data ważności


pole ST_ODS->NA_DNI

Okres przeliczeniowy


pole ST_ODS->PDST_DZN

Podstawa prawna


pole ST_ODS->PDST_NR

Podstawa prawna: nr dokumentu


pole ST_ODS->R

Rodzja odsetek


pole ST_ODS->STAWKA

Stawka odsetek


Stałe miesięczne

Rozliczenie z Urzędami wymaga zastosowania wielu "stałych" danych.
W tej tabelce należy wpisywać dane zmieniające się przynajmniej w cyklu miesięcznym.
Stałe mogą być odczytywane w formułach wyliczeniowych z zastosowaniem funkcji STMSC(<pole>), gdzie pole określa pole tabeli STMSC.

Podobnie jak stałe roczne i stopy odsetkowe można wykonać import danych z internetu wywołując polecenie "import danych"


Stałe programów

Często zmieniające się przepisy oraz różne upodobania użytkowników wymusiły powstanie okienka zawierającego stałe dla wszystkich programów pakietu. Okienko nie wygląda standardowo, tj. tak jak się przyzwyczailiśmy w innych programach z dwóch podstawowych względów. Po pierwsze stałe dotyczą również wersji dla DOS co wymusza nieco inne podejście, a po drugie, taka kontrukcja umożliwia bardzo szybkie odczytywanie z zapisywanie stałych. Program nie musi stosować specjanych procedur odczytu, czy też blokowania stałych. Nie istnieje potrzeba wychodzenia z programu po zmianie danych, po prostu wystarczy zmienić i dalej pracować.


Stałe roczne

Rozliczenie z Urzędami wymaga zastosowania wielu "stałych" danych.
W tej tabelce należy wpisywać dane zmieniające się przynajmniej w cyklu rocznym.
Stałe mogą być odczytywane w formułach wyliczeniowych z zastosowaniem funkcji STROK(<pole>), gdzie pole określa pole tabeli STROK.

Podobnie jak stałe miesięczne i stopy odsetkowe można wykonać import danych z internetu wywołując polecenie "import danych"


tabela STMSC

Tabela STMSC.dbf - stałe miesięczne

RM | miesiąc obowiązywania
MPS | minimalna podstawa składek
MUE | minimalna składka na ubezpieczenie emerytalne
MUR | minimalna składka na ubezpieczenie rentowe
MUC | minimalna składka na ubezpieczenie chorobowe
MUW | minimalna składka na ubezpieczenie wypadkowe
MUZ | minimalna składka na ubezpieczenie zdrowotne
MFP | minimum na Fundusz Pracy
PZU | składka PZU


pole STMSC->MFP

Minimalna składka na Fundusz Pracy


pole STMSC->MPS

Minimalna podstawa składek


pole STMSC->MUC

Minimalna składka na ubezpieczenie chorobowe


pole STMSC->MUE

Minimalna składka na ubezpieczenie emerytalne


pole STMSC->MUR

Minimalna składka na ubezpieczenie rentowe


pole STMSC->MUW

Minimalna składka na ubezpieczenie wypadkowe


pole STMSC->MUZ

Minimalna składka na ubezpieczenie zdrowotne


pole STMSC->PZU

Składka na PZU


pole STMSC->RM

Miesiąc stałych


pole STMSC->SKM_MAX

Stawka za kilometr dla silników powyżej 1,6 litra pojemności


pole STMSC->SKM_MIN

Stawka za kilometr dla silników do 1,6 litra pojemności


Stopy odsetkowe

Poprawne obliczenie odsetek bez wpisania aktualnych stóp jest niemożliwe i dlatego zaleca się wykonywanie ciągłej aktualizacji tej tabli.

Podobnie jak stałe miesięczne i roczne, można wykonać import danych z internetu wywołując polecenie "import danych"


tabela STROK

Tabela STROK.dbf - stałe roczne

SPP | stawka podatku dochodowego od osób prawnych
KUZ | koszty uzyskania - zwykłe
KUP | koszty uzyskania - podwyższone
FG | Fundusz Gwarantowanych Świadczeń Pracowniczych
FEP | Fundusz Emerytalny - pracownik
FEZ | Fundusz Emerytalny - zakład
FRP | Fundusz Rentowy - pracownik
FRZ | Fundusz Rentowy - zakład
FP | Fundusz Pracy
FW | Fundusz Wypadkowy
SC | Składka Chorobowa
SZ | Składka Zdrowotna
KW | Kwota Wolna
ZUSOGR | Ograniczenie składek ZUS


pole STROK->FEP

Fundusz Emerytalny - pracownik


pole STROK->FEZ

Fundusz Emerytalny - zakład


pole STROK->FG

Fundusz Gwarantowanych Świadczeń Pracowniczych


pole STROK->FP

Fundusz Pracy


pole STROK->FRP

Fundusz Rentowy - pracownik


pole STROK->FRZ

Fundusz Rentowy - zakład


pole STROK->FW

Fundusz Wypadkowy


pole STROK->KUP

Koszty uzyskania - podwyższone


pole STROK->KUZ

Koszty uzyskania - zwykłe


pole STROK->KW

Kwota wolna


pole STROK->SC

Składka Chorobowa


pole STROK->SPP

Stawka podatku dochodowego od osób prawnych


pole STROK->SZ

Składka zdrowotna


pole STROK->ZUSOGR

Ograniczenie ZUS


Terminale

Terminale sieciowe


tabela waluta

Tabela WALUTA.dbf

WALUTA | kod ANSI waluty
KOD | kod numeryczny
CECHA | potęga mnożnika
NAZWA | nazwa waluty
KRAJ | kraj obowiązywania
SW | symbol
DROBNE | nazwa drobnych
SWD | symbol drobnych


pole WALUTA->CECHA

Cecha mnożnika


pole WALUTA->DROBNE

Nazwa drobnych


pole WALUTA->KOD

Cyfrowy kod waluty


pole WALUTA->KRAJ

Kraj waluty


pole WALUTA->NAZWA

Nazwa waluty


pole WALUTA->SW

Symbol waluty


pole WALUTA->SWD

Symbol drobnych waluty


pole WALUTA->WALUTA

Symbol waluty w/g ANSI


waluty

Rodzaje walut


Parametry wydruku

Parametry wydruków

Wszystkie programy pakietu zapamiętują ustawienia wydruków dla każdego raportu, komputera i użytkownika. Wśród tych parametów jest drukarka, układ strony i liczba kopii. Zdolność zapamiętywania parametrów jest szczególnie ważna w pracy sieciowej oraz przy wykorzystaniu komputerów przenośnych.


tabela X_MAC

Tabela X_MAC.dbf

MAC | adres/nazwa sieciowa terminala
DF_PORT | port drukarki fiskalnej
DF_TYP | typ drukarki fiskalne


pole X_MAC->DF_PORT

Port drukarki fiskalnej


pole X_MAC->DF_TYP

Typ drukarki fiskalnej


pole X_MAC->X_MAC

Adres sieciowy


Zasoby - indeksy

Wykaz zawiera wszystkie indeksy tabel bazy danych.


Zasoby - pola

Wykaz zawiera wszystkie pola ( kolumny ) tabeli bazy danych.


Zasoby - tabele

Baza danych oprogramowania posiada strukturę przypominającą drzewo.
Pierwszym poziomem tego drzewa jest fizyczna lokalizacja plików zawierających tabele i indeksy. Jak już zapewne wiesz wszystkie dane są zapisane w \BR\BAZY i dalej odpowiednio w podkatalogach odpowiadających ewidencjonowanym firmom.

W tym wykazie umieszczono wszystkie tabele bazy danych, a ich lokalizację określono w polu "Sc."
Każda tabela składa się z pól i rekordów, pole odpowiada kolumnie tabeli, a rekord wierszowi.
Wszystkie pola stanowią strukturę tabeli, która nie jest zmieniana podczas normalnej pracy, lecz może być zmieniana podczas wykonywania aktualizacji oprogramowania. Dane zapisane w rekordach ( wierszach ) są zmieniane w czasie pracy z programem.

Wykaz zawiera wszystkie tabele wraz z opisem i pewnymi parametrami. Dla Ciebie i Urzędów kontrolnych najistotniejszy jest opis.